В старых версиях MSSQL есть меню Maintenance Plans, где имеется настройка создания бекапа баз и тут же есть настройка удаления старых бекап файлов старше -N количество дней. Так вот иногда данная настройка не отрабатывает должным образом. В таком случае мы можем пойти альтернативным путем и настроить удаление через команду forfiles.

Задача


Иногда некоторые вещи, которые кажутся сложными, гораздо проще решить, чем вы думаете, и в этом сила T-SQL для решения повторяющихся задач. Одной из таких задач может быть необходимость резервного копирования всех баз данных на вашем сервере. Это не такая большая проблема, если у вас есть несколько баз данных, но бывают и такие ситуации, где более 100 баз данных на одном и том же экземпляре SQL Server. Вы можете использовать SQL Server Management Studio для резервного копирования баз данных или даже использовать планы обслуживания, но использование T-SQL является гораздо более простым и быстрым подходом в данной ситуации.
Порой в коде 1С необходимо указать возможность выбора каталога для сохранения файла, для данной цели подойдет следующий код:

Процедура КаталогДляПолученияФайловНачалоВыбора(Элемент, СтандартнаяОбработка) 
   СтандартнаяОбработка = Ложь; 
   РежимДиалога = РежимДиалогаВыбораФайла.ВыборКаталога; 
   ДиалогВыбораКаталога = Новый ДиалогВыбораФайла(РежимДиалога); 
   ДиалогВыбораКаталога.МножественныйВыбор = Ложь; 
   ДиалогВыбораКаталога.Заголовок = "Выберите путь для сохранения файлов"; 
   Если ДиалогВыбораКаталога.Выбрать() Тогда 
   КаталогДляПолученияФайлов = ДиалогВыбораКаталога.Каталог; 
   КонецЕсли; 
КонецПроцедуры 

Если, напротив, необходимо написать код для выбора файла, то подойдет следующий код:

Процедура ВыбратьФайл(Элемент)    
    ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогВыбора.Заголовок = "Выберите файл";
    Если ДиалогВыбора.Выбрать() Тогда
        ИмяФайла = ДиалогВыбора.ПолноеИмяФайла;
    КонецЕсли;
КонецПроцедуры

Опрос

Какие языки программирования вы хотите видеть на сайте

Другие опросы...