Выбор файла и Выбор каталога


Порой в коде 1С необходимо указать возможность выбора каталога для сохранения файла, для данной цели подойдет следующий код:

Процедура КаталогДляПолученияФайловНачалоВыбора(Элемент, СтандартнаяОбработка) 
   СтандартнаяОбработка = Ложь; 
   РежимДиалога = РежимДиалогаВыбораФайла.ВыборКаталога; 
   ДиалогВыбораКаталога = Новый ДиалогВыбораФайла(РежимДиалога); 
   ДиалогВыбораКаталога.МножественныйВыбор = Ложь; 
   ДиалогВыбораКаталога.Заголовок = "Выберите путь для сохранения файлов"; 
   Если ДиалогВыбораКаталога.Выбрать() Тогда 
   КаталогДляПолученияФайлов = ДиалогВыбораКаталога.Каталог; 
   КонецЕсли; 
КонецПроцедуры 

Если, напротив, необходимо написать код для выбора файла, то подойдет следующий код:

Процедура ВыбратьФайл(Элемент)    
    ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогВыбора.Заголовок = "Выберите файл";
    Если ДиалогВыбора.Выбрать() Тогда
        ИмяФайла = ДиалогВыбора.ПолноеИмяФайла;
    КонецЕсли;
КонецПроцедуры

Похожие новости

Комментариев 0

Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.